Jump to content


Graphics Problem Running The Two Towers In Vga Mod


  • Please log in to reply
7 replies to this topic

#1 A. J. Raffles

A. J. Raffles

    The Grand Inquisitor

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 6304 posts

Posted 08 November 2005 - 03:48 PM

Link to the Mobygames entry for the game I'm talking of if that's any help.:)

This is a DOS game which works fine on my Windows 98 laptop, but for some reason Windows XP doesn't seem to like it (it wasn't added to Abandonia for that reason, actually). When I tried running the game in DOSBox on my Windows XP computer at home and selected VGA graphics, the intro worked fine, but as soon as the actual game began, the characters just disappeared and turned into a blur on the green background. Oddly enough, I didn't seem to have any problems when I selected CGA mode.

I suppose that means it's a problem with my computer rather than with DOSBox, but might there be any way of tricking the computer, perhaps?

Edit: Dang, I completely forgot I won't be able to access that computer before the first week of December anyway. Oh well, never mind. Sorry for posting.:bye:

Edited by A. J. Raffles, 08 November 2005 - 03:49 PM.


"Flippin' immigrants, stealin' our bandwidth etc. etc." - PrejudiceSucks

#2 Qbix

Qbix

    AR-coholic

  • Members
  • PipPipPipPipPipPip
  • 605 posts

Posted 08 November 2005 - 04:49 PM

Thank you for your detailed report.

To add some more information for future reference:
DOSBox version: 0.63

You can run DOSBox on win98 as well if you feel the urge to test it.
This problem has been fixed (very recently)
It was quite a big problem actually. (has puzzled us quite while)

The game detected the vga card inside DOSBox as a TSENG and did therefore TSENG specific stuff.

I added this fix the code of DOSBox a few weeks ago.

I will test the game to be certain though.

#3 Qbix

Qbix

    AR-coholic

  • Members
  • PipPipPipPipPipPip
  • 605 posts

Posted 08 November 2005 - 06:46 PM

Confiirmed game works.

Can't upload a screenshot it seems.

#4 A. J. Raffles

A. J. Raffles

    The Grand Inquisitor

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 6304 posts

Posted 08 November 2005 - 06:58 PM

Qbix, on Nov 8 2005, 04:49 PM, said:

To add some more information for future reference:
DOSBox version: 0.63
Oops, sorry. Version 0.63 is the only version I ever tried, so I forgot to include that bit. I'll remember it next time.

Quote

You can run DOSBox on win98 as well if you feel the urge to test it.
Actually I did try that, but I'm afraid I'm experiencing Known Problem #1 ("Failed to create rendering output") whenever I try to run DOSBox on my laptop, and I'm not entirely sure whether I understood the suggested solution correctly. What I tried was the bloody obvious, i.e. copying and pasting the line SDL_VIDEODRIVER=windib into the config file, but that didn't make any difference, so I suspect I misunderstood something.
I also followed the link to the SDL site (solution #2) in search of that SDL.DLL file, but I'm afraid I couldn't find it, because the site is a bit confusing if you haven't got a clue what sdl.dll is or what it does exactly. Again, I tried the bloody obvious (checking the "libraries" section), but again, the bloody obvious doesn't seem to be what I'm looking for.

So I'll just try it on the other computer when I get back. But thanks anyway.:)

"Flippin' immigrants, stealin' our bandwidth etc. etc." - PrejudiceSucks

#5 Qbix

Qbix

    AR-coholic

  • Members
  • PipPipPipPipPipPip
  • 605 posts

Posted 08 November 2005 - 07:05 PM

uhm you have to add that
SDL_VIDEODRIVE=windib
to your real autoexec.bat.

#6 A. J. Raffles

A. J. Raffles

    The Grand Inquisitor

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 6304 posts

Posted 08 November 2005 - 08:35 PM

Qbix, on Nov 8 2005, 07:05 PM, said:

uhm you have to add that
SDL_VIDEODRIVE=windib
to your real autoexec.bat.
Ahem. Well, I'll admit I'm somewhat lacking in computer knowledge... Sorry for asking a stupid question, but it wasn't obvious to me from the context.

By opening it in notepad, you mean? Will that change anything about the way other programs are run as well, or will it only affect DOSBox?

"Flippin' immigrants, stealin' our bandwidth etc. etc." - PrejudiceSucks

#7 Qbix

Qbix

    AR-coholic

  • Members
  • PipPipPipPipPipPip
  • 605 posts

Posted 08 November 2005 - 08:38 PM

Will affect all SDL games.
although probably only DOSBox as windib is the default for SDL but we modfied the SDL.dll a bit :) (it's for more speed though)

But please don't change it if you want to help out resolving the "deeper" cause of the problem

#8 A. J. Raffles

A. J. Raffles

    The Grand Inquisitor

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 6304 posts

Posted 08 November 2005 - 09:24 PM

I won't change it. I was just curious, really.

"Flippin' immigrants, stealin' our bandwidth etc. etc." - PrejudiceSucks